Dyn.com - DDOS attacks
Incident Report for emerchantpay
Postmortem

Dear Partner,

Please kindly be advised that if during the Dyn.com DDOS attack you have hardcoded the IP addresses of the Genesis Payment Gateway you should now remove this and revert back to the dedicated DNS names.

Hardcoding of the IP address will prevent the customer to take advantage of the failover in case one of the data centers has issues or throughout maintenance windows and current processing happens through one data center only, however rare this might be.

The Genesis Payment Gateway is hosted in two data centers respectively in Berlin and Amsterdam. As such, it employs load balancing and failover on the DNS layer, and you should be using and requesting the API nodes and web apps only via their dedicated DNS names. Note also that the DNS load balancing and failover layer has a TTL of 30 seconds, and will sense any issues returning the right IP addresses to use, for both API nodes and web apps alike, at all times.

As a highly available payment gateway platform, Genesis strives to achieve an uptime SLA of 99.99 percent on an yearly basis. Thank you for your attention on this matter.

Kind regards, eMerchantPay Tech Support Team

Posted Oct 22, 2016 - 11:10 UTC

Resolved
Dear Partner,

Please kindly be advised that Dyn.com DNS Provider have confirmed the full resolution of the DDOS attack. More information is available on their status page - https://www.dynstatus.com/incidents/nlr4yrr162t8

Kind regards,
eMerchantPay Tech Support Team
Posted Oct 22, 2016 - 07:25 UTC
Identified
Dear Partner,

Please kindly be advised that Dyn.com, the biggest DNS provider used by the top 100 business worldwide, is suffering from DDOS attacks of huge size. Please read here: https://news.ycombinator.com/item?id=12759520

This is an attack with a scale we never saw before.

Our services, are fully up and running, and we have advanced DDOS protection via Prolexic. However, DyNECT outages and issues has impacted us as well, in certain regions only, as most of the internet.

In case you experience issues with DNS resolving in your region, please use our gateway IP addresses directly:

1. Berlin DC -> 5.179.200.54
2. Amsterdam DC -> 5.179.225.54

In addition, our website emerchantpay.com has been mildly impacted, and delays in resolving are seen in certain regions.

Kind regards,
eMerchantPay Tech Support Team
Posted Oct 21, 2016 - 17:14 UTC