emerchantpay - Temporary 3DS network issue 24/03/2025

Incident Report for emerchantpay

Resolved

This incident has been resolved.
Posted Mar 25, 2025 - 11:32 UTC

Investigating

Dear Valued Partner,

We have identified a partial disruption affecting 3DSv2 authentication of transactions processing with Mastercard and VISA.

We are in close communication with the 3DS provider to resolve the problem as soon as possible and keep monitoring the transactions.
Please accept our apologies for the caused inconvenience.

Kind regards,
Technical Support Team
Posted Mar 24, 2025 - 15:49 UTC
This incident affected: PRODUCTION (Genesis - web payment form (PRODUCTION), Genesis - API (PRODUCTION)).